logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Paul Rayman  
#1 Posted : Saturday, December 4, 2021 9:59:36 PM(UTC)
Paul Rayman

Rank: Administration

Groups: Administrators
Joined: 1/5/2016(UTC)
Posts: 1,035

Thanks: 5 times
Was thanked: 122 time(s) in 119 post(s)
Hello,

we have issues with new Dell Latitude 5520 notebooks which have an integrated "Intel Iris Xe Graphics" graphics card.
The problem is the the rendering of the PdfViewer isn't working properly which means that it doesn't refresh its content when you scroll, zoom in/out or change the page via code behind. You can see that something is happening as the borders of pages are shown highlighted in blue/dark grey but the main content stays the same.

UserPostedImage
UserPostedImage



The only way I can solve the issue on these notebooks is to deactivate hardware accelerated rendering and force software rendering
using e.g. the following line of code in Application_Startup or by doing it only for the window which uses the PDFium control.
System.Windows.Media.RenderOptions.ProcessRenderMode = System.Windows.Interop.RenderMode.SoftwareOnly;

We found a link to an error report on Intels forum as it has to do with Intels Iris Xe graphics card and not only PDFium is affected by the problem.
Iris Xe and AWS Workspaces - Page 2 - Intel Community

I have a look at this entry from time to time to see if there is something new from Intel and according to a reply of RonaldM_Intel they’ll hopefully have a driver ready at around June 9th but he notes that this is a target date and may shift depending on additional test results…

Another possibility to fix the issue now would be to set System.Windows.Media.RenderOptions.ProcessRenderMode to System.Windows.Interop.RenderMode.SoftwareOnly but then the whole WPF rendering of the application is done in software.
I think you can also do it on a per window base by getting the WPF windows HwndSource, of that the HwndTarget and the HwndTarget has a RenderMode property which can be set to SoftwareOnly to only render that specific window in software..

You can also disable hardware rendering for all WPF applications in Windows without any modification on your applications code by setting the following registry entries value to 1
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

In case DisableHWAcceleration is missing in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics you must create the value, it’s of type DWORD.
For more information on this see Graphics Rendering Registry Settings - WPF .NET Framework | Microsoft Docs


Update:
Intel finally released an official production driver which fixes the problem.
The version of the driver is 30.0.100.9684 so installing at least this driver version fixes the problem if you don't want to disable hardware acceleration.

It can be downloaded via the following link:
https://downloadcenter.intel.com/download/30579/Intel-Grafik-Windows-DCH-Treiber

Edited by user Sunday, December 5, 2021 12:02:23 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.